Back to overview
Degraded

VocabMaster: Class Creation and Speed Spelling Battle Issues

May 11, 2026 at 1:46am UTC
Affected services
VocabMaster

Resolved
May 28, 2026 at 4:22pm UTC

We have resolved the issues affecting VocabMaster’s class creation and speed spelling battle features. All related functionality, including class visibility and battle access, has been restored and is now operating normally. We are continuing to monitor the system to ensure stability and smooth performance. Thank you for your patience and support while we worked to fix this issue.

Updated
May 20, 2026 at 1:22pm UTC

We are actively addressing multiple issues affecting VocabMaster functionality. Some users may experience partial or missing features while fixes are being deployed.

Updated
May 14, 2026 at 12:32pm UTC

We have identified critical issues affecting VocabMaster’s class management and battle functionality. Our engineering team is actively working to resolve all reported problems.

Issues Under Investigation & Resolution:

Classes not appearing on teacher dashboard – Classes created are not visible to teachers. Investigation and fix are in progress.
Encrypted content display for students – Students see encrypted class IDs (e.g., GbD62y03tAFYu7WcN) instead of readable class names when selecting classes. A decryption issue is being addressed.
Missing battle functionality – The dedicated battle area for student speed spelling battles is currently unavailable. Feature implementation is underway.
Simplified Chinese default template – Vocabulary input currently defaults to Simplified Chinese. We are adding support for a Traditional Chinese template option.
Bulk vocabulary addition inefficiency – We are implementing batch upload and bulk import tools to improve large-scale vocabulary entry for teachers.
Multi-class module assignment – Teachers are unable to assign a single module to multiple classes. Bulk assignment functionality is being added.
Teacher access control issue – Teachers currently have access to all classes regardless of ownership. Role-based access control and proper class restrictions are being implemented.

We are actively working through these issues and will share further updates as progress is made.

Updated
May 11, 2026 at 1:26pm UTC

We have identified critical issues affecting VocabMaster class and battle functionality. Our engineering team is actively working to resolve all reported problems.
Issues Under Investigation & Repair:

Classes not appearing on teacher dashboard - Classes created are not visible to teachers. Investigation and fix in progress.
Encrypted content display for students - When selecting classes, students see encrypted IDs (e.g., GbD62y03tAFYu7WcN) instead of readable class names. Data decryption issue being resolved.
Missing battle functionality - Students lack a dedicated battle "field" or "section" to participate in speed spelling battles with other users. Feature implementation underway.
Simplified Chinese template only - Vocab input defaults to Simplified Chinese. Adding Traditional Chinese gray template option for proper language support.
Bulk vocab addition inefficiency - Teachers need more efficient methods for adding large volumes of vocabulary at once. Implementing batch upload and bulk import features.
Multi-class module assignment - Teachers cannot assign a single module to multiple classes simultaneously. Adding bulk class assignment capability.
Teacher access control issue - All teachers currently have access to all classes regardless of ownership. Implementing proper role-based access control and class ownership restrictions.

Updated
May 11, 2026 at 3:54am UTC

Reported class creation and speed spelling battle bugs are currently being fixed. Users may experience extended wait times when accessing the platform.

Created
May 11, 2026 at 1:46am UTC

VocabMaster is experiencing critical bugs affecting core functionality. Newly created classes are not appearing in the interface, and students cannot create or join speed spelling battles. These issues are preventing users from accessing primary features of the platform.